Steps and Errors encountered in installing SOA SCHEMA

1: Installed the Oracle XE 10g on my local machine.
2: Started the RCU utility.
I received the following error:
RCU:6107 DB Init Param Error

C:Documents and Settingssandsing>sqlplus ‘/’ as sysdba

SQL*Plus: Release 10.2.0.1.0 – Production on Tue Nov 16 16:17:48 2010

Copyright (c) 1982, 2005, Oracle.  All rights reserved.

Enter password:

Connected to:
Oracle Database 10g Express Edition Release 10.2.0.1.0 – Production

SQL> show parameters processes;

NAME                                 TYPE        VALUE
———————————— ———– ——————————
aq_tm_processes                      integer     0
db_writer_processes                  integer     1
gcs_server_processes                 integer     0
job_queue_processes                  integer     4
log_archive_max_processes            integer     2
processes                            integer     600

SQL> ALTER SYSTEM SET PROCESSES=500 SCOPE=SPFILE;

System altered.

SQL> shutdown immediate;
Database closed.
Database dismounted.
ORACLE instance shut down.
SQL> startup
ORACLE instance started.

Total System Global Area  599785472 bytes
Fixed Size                  1288820 bytes
Variable Size             167773580 bytes
Database Buffers          427819008 bytes
Redo Buffers                2904064 bytes
Database mounted.
Database opened.

—————————————–
Then I received the below error:
RCU-6107:DB Init Param Prerequisite failure for: open_cursors. Current value is 300, it should be greater than or equal to 500.

alter system set open_cursors=500 scope=SPFILE;
Restarted DB.

Then I received the following error:

MSG:The OWA_UTIL (Oracle Web Agent) package in the database is missing or out of date, extra time will be required to install this package. Click Ignore to continue with the installation, or Abort to exit.
Error: The Oracle JVM is not installed in the database. It must be installed before loading the portal schema. Please install it and try again.

then I tried running the following scripts:
SQL>  @?/rdbms/admin/pubutil.sql
SQL> @?/rdbms/admin/privutil.sql

Retarted the DB.

Tried running rcu once again:
Still facing the same issue.
SQL> select COMP_NAME, VERSION, STATUS FROM dba_registry;
——————————————————————————–
COMP_NAME                                 VERSION                        STATUS
————–                            —————-             ———–
Oracle Database Catalog Views            10.2.0.1.0                     VALID

Oracle Database Packages and Types        10.2.0.1.0                     VALID

Oracle Text                                10.2.0.1.0                     VALID

COMP_NAME                                 VERSION                        STATUS
——————-                        ———–                     ———–
Oracle XML Database                        10.2.0.1.0                     VALID

SQL> SELECT count(*) FROM dba_objects  WHERE object_type LIKE ‘%JAVA%’;

COUNT(*)
———-
0

This shows that the JAVA VM is not installed for the database.

SQL> SHOW PARAMETER PFILE;
NAME                                 TYPE        VALUE
———————————— ———– ——————————
spfile                               string      D:WLSORACLEXEAPPORACLEPRODUCT10.2.0SERVERDBSSPFILEXE.ORA

SQL> SHOW PARAMETER SHARED_POOL_SIZE
NAME                                 TYPE        VALUE
———————————— ———– ——————————
shared_pool_size                     big integer 0

Since, ORALCE XE does not supports the JVM, I have decided to not install the Portal Schema and then the RCU utiltiy executed successfuly and I was able to create the nesessary schema for all other SOA components except PORTAL.

Please follow and like us:

Please add your comments here